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1 Installing Java Virtual
Folders

Below is a description on how to install Java Virtual Folders on a UNIX operating
system, followed by a description on how to install the folders on a Windows NT
operating system.

Java Virtual Folders for UNIX is installed as follows:

1. The package file names depend on the platform used, and whether native
(nat) threads or green (grn) threads are used. Examples, where xxx
means nat or grn, are as follows:

a) For a Linux platform: hwjvfxxx.tgz

b) For a Hewlett and Packard platform:hwjvfHxxx.tgz

c) For a Sun platform the  options are: hwjvfSUNxxx.tgz

Note: For more information on the packages see the Readme file

2. Copy the Java Virtual Folders package for your architecture to the
directory where you want to install Java Virtual Folders, e.g. your home
directory. If you are a system administrator you can install Java Virtual
Folders globally in a directory such as /usr/local.

3. Unpack the Java Virtual Folders package.  For example, for Linux this is
done as follows:

gzip -dc hwjvfLINnat.tgz|tar xvf -

This will create a directory called HWJVirtualFolders/.

4. Add the HWJVirtualFolders/jvf script to your path. This is done by
extending the path environment variable with the
HWJVirtualFolders/ directory.

e.g. setenv path=(~/HWJVirtualFolders $path)

Or by linking the script to a directory which is currently in the path.

e.g. cd /usr/local/bin

ln -s /usr/local/HWJVirtualFolder/jvf

The first time you start Java Virtual Folders, a directory called .hwjava is
created in the user’s home directory. This directory is used to store the various
configuration files.

Note: It is recommended to set the access rights of the .hwjava directory to have
read/write access only for the owner (e.g. cd; chmod 700 .hwjava).

INSTALLING UNDER
UNIX
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Java Virtual Folders for Windows NT is installed as follows:

1. Double click on the package with the file name hwjvf.exe

2. Wait while the Install Shield Wizard works automatically. The Hyperwave
Software License Agreement then appears.  See Figure 1.

Figure 1: The Hyperwave Software License Agreement

3. Read the license text carefully, then click on the Yes button to accept the
license agreement.  The Hyperwave Setup dialog box appears.  See Figure
2 below.

INSTALLING UNDER
WINDOWS NT
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Figure 2: Hyperwave Setup

4. You can save the Virtual Folders files to the default destination directory,
or change the path by click on the browse button next to the default path
name.  Choose your own destination from the list menu displayed in the
pop-up dialog box.  Click on the OK button to process, or cancel to
return to the default destination.

5. Click on the Next button in t he Hyperwave Setup dialog box; the Java
Virtual Folders will be installed on your computer.  Wait while the files
are copied to your directory destination.  See Figure 3.
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Figure 3: Installing Hyperwave Java Virtual Folders

6. A query dialog box appears which asks you if you wish to view the
Hyperwave Java Virtual Folder Readme file now.  Depending on your
choice, click on the Yes or No button.  If you click on Yes the Readme file
appears; X to close the Readme window.

7. The next dialog box give you the option of rebooting you computer
straight away or later. Click the desired option, and click on the OK
button.  If you wish to restart the computer immediately, make sure all
other data is saved.

Figure 4: Restarting Windows dialog box



5

Hyperwave Administrator’s Guide – Installing Java Virtual Folders

8. The final dialog box informs you the Hyperwave Java Virtual folders were
installed successfully; click on the OK button to close.

9. You can find the installed files in the destination directory.

Note: It is recommended to set the access rights of the hwjava directory to have
read/write access only for the owner (e.g. cd; chmod 700 hwjava).
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2 Configuring Java Virtual
Folders

2.1 Configuring Viewers

Java Virtual Folders can be configured to open certain document types with
certain viewers. Viewers are searched in the following order:

ì Java Viewer

ì Native Viewer

ì Browser

Each viewer component can be configured. You can set entries in the
configuration files in:

1. the $HOME/.hwjava/ directory for UNIX

2. the  $HOME/hwjava/ directory for Windows NT

This will overwrite entries in the global configuration files in following
subdirectory of the installation directory:

1. the .hwjava/subdirectory for UNIX

2. the hwjava/subdirectory for Windows NT

Note: When no files (e.g. hwjvf.properties), are found in the directory
$HOME/.hwjava (UNIX) or $HOME/hwjava (Windows NT),the data is read
from the original global configuration file.

Note: This section applies to UNIX only.

To configure the browser you wish to use to view documents from Java Virtual
Folders:

1. Open the file:

a) .hwjava/hwjvf.properties for UNIX

b) hwjava/hwjvf.properties for Windows NT

2. Create (or modify) the value for the key
application.to_start_for_url

The default value for this key is:

application.to_start_for_url= netscape –remote
"openurl(%u)"

To configure the native (non-Java) viewers you wish to use to view documents
from Java Virtual Folders:

CONFIGURING THE
BROWSER

CONFIGURING NATIVE
VIEWERS
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1. Open the file:

a) .hwjava/hwjvf.properties for UNIX

b) hwjava/hwjvf.properties for Windows NT

2. Add a viewer for a particular mimetype by entering the key
application.to_start.[mimetype]

Where [mimetype] is the document type for which the new viewer should
be registered.

3. Enter the viewer command as the value for this entry, for example:

application.to_start.text/java=emacs

or

application.to_start.image/*=xv

Note: This section on Configuring Java Viewers is for programmers’ use only.

A Java viewer is the most efficient way to add viewers. It can also be used to add
additional features such as edit, send mail, print, etc. The Java class which is to
act as a viewer (or editor, or printer) must implement the CommandObject
Interface as defined in the Java Activation Framework.

To configure the Java viewers you wish to use to view documents from the Java
Virtual Folders:

1. Open the file:

a) .hwjava/commandmap.txt for UNIX

b) hwjava/commandmap.txt for Windows NT

This file uses the same syntax as a mailcap file (RFC 1524).

2. Add the line

text/rtf;;x-java-view=com.foo.RTFViewer

where com.foo.RTFViewer is a Java viewer class you have written for
viewing RTF documents.

Note: Make sure your viewer class and its helper classes are in your CLASSPATH
environment variable.

Note: This section on Configuring Edit print Commands is for programmers’ use
only.

To add any other command to a mimetype, like edit, print, mail etc., you must
enter x-java-[command] where [command] is to be replaced by the specified
command.

CONFIGURING JAVA
VIEWERS

CONFIGURING EDIT,
PRINT COMMANDS
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The name of this command will also be used as a menu item name for the
context-sensitive menu where you can select a viewer. Registered commands will
only be selectable if you have write access to the object. If your command is really
only a viewer and does not change the content of the object, you can register it as
read-only. Add the command name to the
application.command_readonly key in the file:

a)  /.hwjava/hwjvf.properties for UNIX

b) /hwjava/hwjvf.properties for Windows NT

2.2 Configuring Help Files

It is possible to configure Java Virtual Folders such that your own personal Help
files can be accessed while you are working.

1. Open the configuration file:

a) /.hwjava/hwjvf.properties for UNIX

b) /hwjava/hwjvf.properties for Windows NT

2. Find the entry application.help.URL and change the value as
required:

Enter the URL (of a Hyperwave Information Server) as the value of this
configuration variable, or enter the path (absolute path or path relative to
installation directory) to your Help files on the file system as the value for
this configuration variable.

The default value for this variable is html/help/hwjvf.html. You can
also modify the HTML of this file to include links to other Help files that
you have included in the directory.
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3 Using Java Virtual Folders

Java Virtual Folders are a device for UNIX platforms that works in much the
same way as Virtual Folders for Windows NT. Java Virtual Folders allow you to
navigate collections, view and delete objects, carry out Version Control and
Configuration functions on objects, and view and edit object attributes.

3.1 Starting Java Virtual Folders

To start Java Virtual Folders using UNIX, enter:

jvf

in the command line prompt. Java Virtual Folders appears as seen in Figure 5. In
order to browse HWIS collections and directories in the file system, these must
be added as described in the next section.

Figure 5: Starting Java Virtual Folders for the first time(UNIX)

OVERVIEW
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To start Java Virtual Folders using Windows NT, click on the Start button of the
bottom tool bar then click as follows:

Program È Hyperwave Virtual Folders È  Hyperwave Virtual Folders. Java
Virtual Folders appears as seen in Figure 6. In order to browse HWIS collections
and directories in the file system, these must be added as described in the next
section.

Figure 6: Starting Java Virtual Folders for the first time (Windows NT)

3.2 Adding a Server or File
System

In order to access HWIS and file systems through Java Virtual Folders, you must
use the procedures described in this section to add them to JVF. Note that Java
Virtual Folders "remembers" which Hyperwave Information Servers and file
systems you added during your previous sessions, and will display these
automatically when started the next time.
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3.2.1 Adding a Server

To add (mount) a server in Java Virtual Folders, take the following steps:

1. There are three ways to start this process:

ì choose the command Add Hyperwave Server from the Tools menu

ì click on the  icon in the toolbar

ì click with the right mouse button in empty space of the Java Virtual
Folders view, and choose Add Hyperwave Information Server (HWIS)
from the context-sensitive menu that appears.

The dialog box in Figure 7 appears.

Figure 7: The Add  Hyperwave Server dialog box

2. This dialog box contains the three tabs General, User Identification, and
Proxy Settings.

Under the General tab enter the following:

Host: The host name of the HWIS you want to connect to. Do not
preface the name with "http://"

Port: The port number of the server you are connecting to (optional). If
the protocol you are using is HGCSP, the port number should be 418. For
HWTP, enter 80 as the port number. Default is 80.

Collection: Enter the Name attribute of the collection you want as your
entry point to the server. If no entry is made here, the root collection of
the server will be taken as entry point.

Title: After the server is added, this text appears as the title of the server
added, so it should be descriptive.

Under User Identification (Figure 8), enter the following (optional):

User: Your user name on the HWIS you are connecting to

Password: Your password on the HWIS you are connecting to

Entering this information makes it so that you will automatically be
identified on the server during subsequent sessions with Java Virtual
Folders.

GENERAL SETTINGS

USER IDENTIFICATION
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Figure 8: Adding a Server: User Identification information

The tab Proxy Settings (Figure 9) allows you to enter information about
a proxy server. These entries must only be made if you are connecting to
the desired server over a proxy.

Figure 9: Adding a Server: Proxy Setting information

3. When you have entered all the relevant information, click on the OK
button.

3.2.2 Adding a File System

To add a file system to Java Virtual Folders, take the following steps:

1. There are three ways to start this process:

ì choose the command Add File System from the Tools menu

ì click on the  icon in the toolbar

ì click with the right mouse button in empty space of the Java Virtual
Folders view, and choose Add Hyperwave Server from the context-
sensitive menu that appears.

The dialog box in Figure 10 appears.

PROXY SETTINGS
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Figure 10: Adding a File System

2. Enter the path of the file system you wish to add to the Java Virtual
Folders view (your home directory appears as suggested directory), or
browse for it by clicking on the Browse button. Add a title under which
the file system will be displayed in Java Virtual Folders.

3. Click on the OK button.

3.2.3 Displaying a Collection

Once you have added a HWIS collection or file system, Java Virtual Folders
displays it in the same way as Microsoft Windows Explorer displays file systems
(Figure 11). HWIS collections are displayed with a yellow folder icon. File
systems are displayed with a gray folder icon.

Note: When an object has more than one name this is indicated by a “+”next to the
relevant name.

Figure 11: Java Virtual Folders displaying Hyperwave Collection listings and a
mounted file system

3.2.4 Navigating in Java Virtual Folders

Navigation in Java Virtual Folders is done as follows:
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ì Single-click on a collection or directory in the left window to display its
contents in the right window.

ì Click on the  icon, or double-click on the folder icon to list the content
of a collection or directory in the left window.

ì Choose Refresh from the View menu or click on the  icon to refresh
the Java Virtual Folders view. You can also press the F5 key on your
keyboard to refresh the Java Virtual Folders view.

ì Click on the  toolbar icon to go up one hierarchical level.

3.2.5 Identifying Yourself via Java Virtual
Folders

When adding a server, you can enter user identification information, which will
be stored with the server entry. In this way, it is not necessary to log in every time
you access a collection listing on Java Virtual Folders. However, if you did not
store this identification information or if you would like to log in under another
user name, you can do this as follows:

1. Click on the added collection name with the right mouse button. The
context-sensitive menu seen in Figure 12 appears.

Figure 12: Context-sensitive menu

2. Select User Identification from this menu. The dialog box in Figure 13
appears.

3. Enter your user name and password in this dialog box.

4. Click on the OK button.

Figure 13: User Identification dialog box
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3.3 Displaying Objects in your
Web Browser

To display an object listed in the collection listing, click on its name or icon with
your right mouse button and choose the command Browse from the context-
sensitive menu. The object will be loaded in your browser window.

If the object you selected for display is a collection, its hierarchy (parents and
children) will appear in the browser window.

It is possible to configure Java Virtual Folders so that certain file types will always
be viewed with certain applications. For more information on configuring Java
Virtual Folders, see page 6.

3.4 Java Virtual Folders Menus

3.4.1 Menus on the Menu Bar

The menus in the Java Virtual Folders menu bar are File, Edit, View, Options,
Tools and Help.

The File menu contains the commands New Virtual Folders, Close and Quit.

The New Virtual Folders command opens a second Java Virtual Folders
window.

The Close command closes subsequent Java Virtual Folders windows opened
with the New Virtual Folders command.

The Quit command exits Java Virtual Folders.

The Edit Menu contains the commands Cut, Copy, Paste, Link, Link Version,
Delete, Select All and Invert Selection.

The Cut, Copy, Paste and Delete commands retain their standard Windows
functions.

The Link command lets you create a shortcut from a collection to a document or
collection on the same HWIS. See page 18 for a description of how to set links.

With the Link Version command, you can create a shortcut to a particular
version of a document in any collection on the same Hyperwave Information
Server. See page 18 for a description of how to set a link to a version.

The Select All command selects all objects that are currently displayed in the
right-hand Java Virtual Folders window.

The Invert Selection command inverts the current selection.

The View menu contains the commands: Refresh and Refresh All.

THE FILE MENU

THE EDIT MENU

THE VIEW MENU
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Refresh refreshes the display of the selected object in Java Virtual Folders. You
can also refresh the view by.  You can also press the F5 key on your keyboard or
click on the  icon in the toolbar to refresh the Java Virtual Folders view

Refresh All reloads the Java Virtual Folders display for all objects.

The Options menu contains the option Hyperwave Language, which allows you
to select a display language from a list.

The Tools menu contains the commands: Add Filesystem, Add Hyperwave
Server and Remove.

The Add Filesystem and Add Hyperwave Server commands allow you to add
file systems and servers to the Java Virtual Folders as described on page 10.

The Remove command allows you to remove the selected servers and/or file
systems from Java Virtual Folders.

The Help menu gives you access to Java Virtual Folders Help and to information
on the Java Virtual Folders version number, etc.

3.4.2 The Context-Sensitive Menu

As with Microsoft Windows Explorer, a context-sensitive menu appears when
you click with the right mouse button on a collection, directory or document in
Java Virtual Folders. The commands available on this menu depend on what
object you have clicked on, whether you have write rights to the object, whether it
is version controlled, etc.

The possible commands that will be displayed on the context-sensitive menu are
Open, Close, Open With , Browse, Cut, Copy, Paste, New4, Delete, Show
Properties, Link Map, Properties, Modify Attributes, Version Control,
Check In, Check Out, Configuration, Clear DC Cache, Preferences, User
Identification, Remove. What these options do, and which documents they
appear on the context-sensitive menu for is explained below.

Open opens the selected object in the specified application or browser. If the
object is already open when you right click on it and is a collection or directory,
the menu option will read Close.

Open With  only appears when the object you are clicking on is not a
collection or a directory (e.g. a text file,  an MSWord document, a picture file,
etc.). It allows you to enter the name of an application to open the file.

Browse opens a browser window to view the contents of a document, or the
hierarchy of a collection.

Cut, Copy and Paste carry out their normal Windows functions.

New4 has its own sub-menu that allows you to insert a new object. This item
only appears if the current object is a collection.

Delete removes the selected object from the collection. If you choose Delete, you
will be prompted with a dialog box asking if you really want to remove the
selected object. If the object you choose to delete is a collection, any descendants
will also be deleted.

THE OPTIONS MENU

THE TOOLS MENU

THE HELP MENU

FILE MANAGEMENT
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Edit appears on the context-sensitive menu when an editor exists for the object
you have clicked on. This is configurable (see page 7). If you choose this
command, the text document (for example) will be opened in a viewer window
where you can make changes to the content and then click on Save in the File
menu.

Note: You can only use the Edit command on version controlled documents if you
check them out first!

Show Properties appears on the context-sensitive menu when you do not have
write rights for the object, or you are an unidentified user, or the object is under
version control. It allows you to view the attributes of an object. When you
choose Show Properties from the context-sensitive menu, a dialog box appears
where all attributes and values for the object are displayed (Figure 14). It is not
possible to modify the attributes from this dialog.

Figure 14: Show Properties dialog box

Properties: the Properties command only appears when you have write rights to
the object in question. This command allows you to modify attributes for single
objects. If you wish to modify attributes recursively (i.e. for all children of a
collection), you must choose the command Modify Attributes. The Properties
command is explained in more detail on page 21.

Link Map is described in more detail on page 43

Modify Attributes only appears in the context-sensitive menu when you click on
an object that has children or if you selected multiple objects (and you have write
rights for the objects). This command allows you to modify attributes recursively
for all children of a collection. It is explained in more detail on page 23.

Version Control allows you to view the Version History of an object, and to
access all other Version Control functions. It is explained in detail on page 29.

Check In appears for documents for which you have write rights, and which are
not yet under version control, or which are version controlled and are checked
out. This command allows you to check in the document, enter a comment, set a
version number etc. (see page 32).

ATTRIBUTE
MANAGEMENT

DOCUMENT
MANAGEMENT
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Check Out appears for documents for which you have write rights, and which
are version controlled and checked in. This command allows you to check out
any version of the document.

Configuration only appears when the object you pick on is a collection or
directory. The Configuration command allows you to save collections as
configuration files and manage existing configuration files. Using configurations
with Java Virtual Folders is described in more detail on page 33.

Clear DC Cache appears when you click on a mount point (the HWIS or file
system you have added for Java Virtual Folders). This command clears the cache
used by the Document Classes feature.

User Identification allows you to identify yourself to the system over the Java
Virtual Folders, as explained on page 14.

Remove allows you to remove added HWIS collections or file systems. Remove
will only appear on the context-sensitive menu if the object you have clicked on is
the root of the added collection. You can also remove selected root collections or
directories by clicking on the  icon in the toolbar.

Preferences only appears in the context-sensitive menu when you click on the
added HWIS collection. The Preferences command allows you to set preferences
for uploading and downloading collections. It is described in more detail on page
33.

3.5 Linking Documents in Java
Virtual Folders

It is possible to make a link to a document or to a specific version of a version-
controlled document with JVF. These procedures are described below.

3.5.1 Setting Links

To set a link to a particular document:

1. Select the document you are making the link to.

2. Copy the document (Edit→Copy or CTRL-c).

3. Select the target collection for the linked document.

4. Select Edit→Link (or press CTRL-L).

3.5.2 Linking to a Version

To set a link to a particular version of a version controlled document:

JAVA VIRTUAL
FOLDERS

MANAGEMENT
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1. Select the document you want to make the version link to.

2. Copy the document (Edit→Copy or CTRL-c).

3. Select the target collection for the linked document.

4. Select Edit→Link Version (or press CTRL-SHIFT_L). A dialog box
listing all the versions of the document appears (see Figure 15).

5. Select the version you want to make the link to.

6. Click on OK.

Figure 15: Selecting a version to link

3.6 Inserting New Objects into
HWIS with Java Virtual
Folders

It is possible to insert new collections and documents into HWIS with Java
Virtual Folders.

Note: When an object has more than one name this is indicated by a “+”next to the
relevant name. See Section 3.7 for how to edit an attribute and add an extra name.

3.6.1 Inserting a New Collection

A new collection is inserted as follows:

1. Click with your right mouse button on the collection into which you
would like to insert a new collection. A context-sensitive menu appears.

2. Select New from this menu. A further menu appears.

3. Select New Collection from this menu. The Create a new Collection
dialog box appears (Figure 16).

4. Enter a Name (URL or path) for the new collection.
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5. Choose a two-letter language abbreviation for the title and enter the Title
in the text box.

6. Choose a Collection Type for the collection.

7. Click on the OK button.

Figure 16: Creating a new collection

3.6.2 Inserting a New Text

A new text is inserted as follows:

1. Click with your right mouse button on the collection into which you
would like to insert a new text. A context-sensitive menu appears.

2. Select New from this menu. A further menu appears.

3. Select New Text from this menu. The New Text Document dialog box
appears. Type your text directly into this dialog and use the menus and
toolbar to access basic editing functions (Figure 17).

4. When you have finished creating your text, select File ÈSave or click on
the Save icon in the toolbar. You will be prompted to enter information
about the text.

5. Choose a two-letter language abbreviation for the title and enter the Title
in the text box.

6. Enter an optional Description for the text.

7. Click on the OK button.
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Figure 17: Creating New Text

Figure 18: Entering Title information for new text

Inserting new HTML is completed in the same way as inserting new text, as
described above. The only difference is that the New HTML dialog already
contains basic HTML tags.

3.7 Editing Attributes with Java
Virtual Folders

With Java Virtual Folders, you can edit the attributes of a single object
individually or you can recursively modify the attributes of a collection.

3.7.1 Editing Attributes of a Single
Document

Choosing the Properties item in the context-sensitive menu allows you to add,
remove and modify the attributes of an object. Note that may not edit the
attributes of documents if you do not have write rights to the object, or if you are
not an identified user, or if the document is version-controlled and checked in.

INSERTING A NEW
HTML TEXT
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The properties (attributes) of an object are edited as follows:

1. Click on the object whose properties you wish to change with your right
mouse button. A context-sensitive menu appears.

2. Select Properties from the menu. The dialog box in Figure 19 appears.
This dialog box lists all the attributes for the object. You may modify
attributes whose values have a white background. Attributes shown in
gray cannot be modified.

3. To add a new attribute, select the attribute type from the listbox at the
bottom of the dialog box, or enter an attribute type manually here.

4. Click on the Add button. The attribute you have chosen will appear as a
new pair of cells in the dialog box (you may have to scroll down to see it).

5. Add the required value for the attribute.

Note that if the attribute you are adding is a Rights attribute, a button
labeled Rights Wizard will appear. You can use the Rights Wizard to help
you set access rights for different users. The Rights Wizard for Java Virtual
Folders is explained on page 27.

6. Click on the Apply button to apply the changes.

7. To delete an attribute, select the attribute by clicking on it (a blue line will
appear around it) and then click on the Delete button. The attribute will
disappear from the listing.

8. Click on the Apply button to apply the changes.

9. Click on the OK button to exit the dialog box.
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Figure 19: Edit Properties dialog box

3.7.2 Editing Attributes Recursively

It is possible to edit the attributes of all the objects in a collection or those of a
group of selected objects with the Modify Attributes function.
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Figure 20: Modify Attributes dialog box

Attributes of multiple documents or collections are edited as follows:

1. Click with your right mouse button on the collection(s) whose attributes
you want to modify. A context-sensitive menu appears.

2. Select Modify Attributes from this menu. The Modify Objects dialog box
(Figure 20) appears.

3. Make sure you have a list of the attributes you want to add, remove and
change. Click on the Add, Remove or Change button (depending on
what you want to do).

Adding an Attribute:

a) Click on the Add button in the Modify Objects dialog box. The Add
Attribute dialog box appears (Figure 21).

b) Select an attribute type from the listbox or enter an attribute type
manually in the textbox under the attribute listing.

c) Enter a value for the attribute in the Attribute Value textbox. If you
are entering a Rights attribute, you can use the Rights Wizard to enter
the value by clicking on the Rights Wizard button. The Rights Wizard
is explained on page 27.

d) Click the OK button. The attribute you want to add will appear in the
large text box in the Modify Objects dialog box.

MODIFYING
ATTRIBUTES OF

COLLECTIONS
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Figure 21: Add Attribute dialog box

Removing an Attribute

a) Click on the Remove button in the Modify Objects dialog box. The
Remove Attribute dialog box appears (Figure 22).

b) Select an attribute type from the listbox or enter an attribute type
manually in the textbox under the attribute listing.

You can remove a particular instance of an attribute by entering the
value associated with that attribute. For example, if an object has two
Titles, one in English and one in German, but you only want to remove
the German title: enter the value associated with the German title in the
second text box. The English title will not be affected.

c) Click the OK button. The attribute you want to delete will appear in
the large text box in the Modify Objects dialog box.
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Figure 22: Remove Attribute dialog box

Changing an Attribute

a) Click on the Change button in the Modify Objects dialog box. The
Change Attribute dialog box appears (Figure 23).

b) Select an attribute type from the list box or enter an attribute type
manually in the Name textbox.

c) Enter the current value of the attribute in the textbox labeled Change
attribute value from. You may use a wildcard (*) in this value. If you
are entering a Rights attribute, you can use the Rights Wizard to enter
the value by clicking on the Rights Wizard button.

d) Enter the value you want to give to the attribute in the textbox labeled
Change attribute value to. If you are entering a Rights attribute, you
can use the Rights Wizard to enter the value by clicking on the Rights
Wizard button. The Rights Wizard is explained on page 27.

e) Click the OK button. The attribute you want to change will appear in
the large text box in the Modify Objects dialog box.
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Figure 23: Change Attribute dialog box

4. Apply the changes by clicking on the OK button.

After clicking the OK button, a dialog box will appear displaying the progress of
the modification of the attributes. This dialog box logs any errors that occur.

3.7.3 Rights Wizard

The Rights Wizard allows you to set permissions for individual objects without
having to remember the syntax of the Rights attribute or the valid user and group
names (see Figure 24).

Using the Rights Wizard, you can set read, write or unlink rights for different
user and groups.

The Rights Wizard is used as follows:

1. Search for the desired users or groups as follows:

Activate the Users and/or Groups checkboxes, depending on which type
you want to search for.

Click on the letter tab corresponding to the first letter of the user or group
name(s) you are searching for, and click on the Search button. All user
names corresponding to the letter you picked will appear in the column
on the left of the dialog box. To list all available users and groups, click on
the All button.

RIGHTS WIZARD
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2. Select the user (or group) for which you want to set rights, and click on
the right arrow button. The user or group name will be moved to the
viewing window on the right.

3. Select the name(s) in the right column for which you want to set rights.
Use your Ctrl key to select multiple user/group names that do not appear
one after another. Use your Shift key to select a sequential group of
user/group names. Selected names will show outlined with a blue shadow.
Activate the appropriate checkboxes (W= write, U= unlink, R= read)
according to the type of rights you want to grant to the selected users and
groups.

The corresponding letters will appear next to the names in the column
listing.

4. To delete an entry from the right column, select the entry and click on the
left arrow button.

5. When you have set all the rights to your satisfaction, click on the OK
button. The syntax of the Rights you have assigned appear in the attribute
value text box in the Add Attribute dialog box.

Figure 24: Rights Wizard
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3.8 Version Control

3.8.1 How Version Control Works

Hyperwave Information Server’s Version Control feature lets you save and
retrieve all the versions ever created of a document on the server.

Documents on Hyperwave Information Server are not automatically version
controlled. If you want a document to be version controlled, you must use the
Check in function on it. This assigns a version number to the document (starting
with 1.0), and makes it so that no one can edit the document unless he or she has
used the Check out function on it. When a user checks out the document, it is
automatically locked for this user, meaning that only this user can edit it until it is
checked in again. At check in, you can select the checkbox labeled Check in only
if content changed, in which case, a new version will only be created and the
version number increased, if there have been any changes made to the document.

Starting with version 5.1 of the HWIS, it is possible to check out a version other
than the most recent version. You will be prompted with a dialog box that allows
you to choose which version to check out. If you would prefer that this dialog box
did not appear, and that you could check out documents in the usual manner,
you should deselect the checkbox in Preferences (Version Control Options
tab) labeled Show version selection dialog on check out. See page 42 for more
information on setting preferences.

When a document has been checked out by a user, it is called an experimental
version. After the document has been checked in, the new version is called the
last committed version.

With the Set Committed Version function, you can commit a version other
than the most recent version. This version will then be displayed in the collection
listing for all other users with read rights to access, and users with write rights can
continue working on further versions of the document.

With the Revert to Version function you can go back to any version in the
history of a document and use it as the most recent version (last committed
version).

With the Take out Version function, you can select a particular version of a
document from the version history and remove it from version control. All other
versions of the document will be deleted.

Note: This version will now reside on the server as a normal document, not under
version control. All other versions of this document will be deleted from the server. It
is not possible to execute this command with experimental versions.

With the Delete function, you can select a certain version of a document from
the version history and delete that single version. You can also choose to delete all
versions older than the selected one from the server.

You can view the complete version history of a document in the Version Control
dialog box (Figure 25), including the version number, the user who created the
version and the time it was created. For each entry in the list the title of the

CHECK IN AND CHECK
OUT

EXPERIMENTAL AND
LAST COMMITTED

VERSION

SET COMMITTED
VERSION

REVERT TO VERSION

TAKE OUT VERSION

DELETE

VERSION HISTORY
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version with a link to that version is shown, so you can easily view any version in
the history.

Under the Edit menu in Java Virtual Folders, you can create a link to a particular
version of a document, see page 18.

3.8.2 Version Control in Java Virtual
Folders

When you select the command Version Control from the context-sensitive
menu, a dialog box will appear that allows you to view the version history of the
selected object and gives you access to the version control functions: Check In,
Check Version, Revert, Delete and Take Out (see Figure 25).

To apply these commands to a version of a document:

1. Right click on the object you wish to apply the Version Control command
to.

2. From the context-sensitive menu that appears, choose the option Version
Control.

3. In the Version Control dialog box, click on the version on which you
want to perform the version control function and click on the appropriate
button (Check In, Check Out, Revert, Delete, Take Out, Set
Committed Version).

4. Click on the Close button to exit the dialog box.

Figure 25: The Version Control dialog box

CREATING A VERSION
SHORTCUT
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If you double click on any version in the Version Control dialog box, a secondary
dialog box will appear, displaying the comment that was entered with that
version. See Figure 26.

Figure 26: Version Control dialog with version comment

It is also possible to apply the Check In and Check Out commands directly from
the context-sensitive menu, without opening the Version Control dialog box.

Check Out will only appear on the context-sensitive menu when you click on an
object for which you have write rights and which is version controlled.

Check In will only appear on the context-sensitive menu when you click on an
object for which you have write rights and which are not yet version controlled,
or which are version controlled and checked out.

To check out a document:

1. Click with your right mouse button on the document you wish to check
out

2. Choose Check Out from the context-sensitive menu. A dialog box
appears showing all versions existing for the document (Figure 27).

3. Choose the version you wish to check out.

4. Click on the OK button to check out the version.

If you select the checkbox labeled Do not show this dialog next time,
you will only be able to check out the most recent version of the
document with this method. You will still be able to check out previous
versions by accessing the Version Control dialog box (see page 30).

A notification dialog will display the progress of the check out action, and
list any errors that might occur.

VIEWING COMMENTS

CHECK OUT / CHECK
IN FROM CONTEXT-

SENSITIVE MENU

CHECK OUT A
DOCUMENT
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The document now appears in the Java Virtual Folders view as an experimental
version.

Figure 27: Check Out dialog box

It is also possible to check out more than one document at a time. To check out
multiple documents:

1. Select the documents you wish to check out by clicking on them once.
Select sequential documents by holding down your shift button and
clicking, select documents that are not next to each other by holding down
your control button (Ctrl) and clicking.

2. Click with your right mouse button on one of the selected documents.

3. Choose Check Out from the context-sensitive menu. You will not be
given the option to check out previous versions of the documents. The
most recent version of all documents will be checked out.

To check in a document:

1. Click with your right mouse button on the document you wish to check
in.

2. Choose Check In from the context-sensitive menu.

3. A dialog box appears where you can enter a comment and set the version
number for the new committed version (see Figure 28).

If you select the checkbox Check in only if content changed, the
document will only be checked in if its content has been modified. If the
content has not been changed, the previous version number will be
reverted to and the experimental version deleted.

CHECK OUT MULTIPLE
DOCUMENTS

CHECK IN A
DOCUMENT
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A dialog box appears showing the progress of the action, and listing any
errors that might occur.

The document now appears in the Java Virtual Folders view with its new version
number.

Figure 28: Check In dialog box

3.9 Configurations

3.9.1 How Configurations Work

The Configurations function allows you to manage collections and hierarchies in
a very effective way. With Configurations , you can save any collection in its
current hierarchical form. In other words, all objects will be saved, as well as the
meta-information on objects, and structural information regarding how the
collection is configured. The Configurations feature is similar to Version Control
in that it stores previous versions (in this case collection hierarchies, rather than
single objects), allows you to replace the current configuration with an older
configuration, allows you to load previous configurations to the server without
overwriting new content, and allows you to browse previous configurations.

The Save function allows you to save a collection as a configuration. The selected
collection and its contents are saved to a configuration file. This collection is now
given a special attribute HW_ArchiveType with the value "Configuration". The
configuration file is assigned a major and minor version number. You can also
enter a comment on the configuration to be saved.

Only the most recent version of a configuration is stored in the Hyperwave
Information Server database (this version is labeled "current" in the
Configuration Control dialog box). All previous versions are saved in separate
configuration files.

SAVING A
CONFIGURATION
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Only the most recent version of a configuration can be modified. All previous
configurations are stored in static files outside the database.

Collections that are configurations appear on the Hyperwave Information Server
interface with a special icon. This icon looks like the standard Collection icon,
with a small red C in the bottom right hand corner .

The Restore  function allows you to restore a previous configuration to the
Hyperwave Information Server database. This function assigns the restored
configuration as the most recent version, and the configuration that had until
now been the most recent version is deleted. You can identify which
configuration in the history you wish to restore by its major and minor version
numbers.

Only when a previous configuration is restored to the database can it be
modified, as it is no longer stored in a static file.

The Merge function allows you to restore a previous configuration to the
Hyperwave Information Server without overwriting the most recent version. In this
way, it differentiates itself from the Restore function. The previous configuration
is loaded to the Hyperwave Information Server database, incorporating any
changes that have been made since it was last saved and assigning it as the most
recent version. Again, the configuration to be loaded is identified by its major and
minor version number.

In the Configuration Control dialog box (Figure 29), you can view all previous
configurations for a configuration object. Configuration objects are listed with
their major and minor version numbers, the user who saved them, the date they
were saved and the GOid attributes. All previous configurations can be
transparently browsed using your web browser. There is no need for any extra
tools.

All objects belonging to archived configurations can be identified by the attribute
HW_Configuration. The value of this attribute is the GOid of the root collection
of this configuration.

The Delete function allows you to delete archived configurations from the
configuration history. It is not possible to delete the current configuration, as it
exists on the server and is not stored as an archived file.

3.9.2 Configurations in Java Virtual
Folders

The Configuration command in the context-sensitive menu allows you to access
all the functions of Hyperwave Information Server’s Configurations feature.

When you choose this option from the context-sensitive menu, the
Configuration Control dialog box will open (see Figure 29).
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CONFIGURATIONS
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In this dialog box, you can save new configurations from objects in Java Virtual
Folders, merge and restore previous configurations to the server, delete
configurations and select configurations for display. The dialog box displays all
previous configuration objects as well as the current configuration, which is
active on the server. Previous configurations are displayed with their version
number, the user who created the configuration, the date and time they were
created and the GOid of both the configuration object and the root collection.
You can also view comments that were entered with configurations.

Figure 29: Configuration Control dialog box

To save a new configuration:

1. Right click on the collection in Java Virtual Folders window that you wish
to save as a configuration.

2. From the context-sensitive menu, choose the option Configuration

3. In the dialog box that appears, click on the Save button.

4. The collection you created will be stored as a configuration and will
appear in the configurations listing in the Configuration Control dialog
box.

5. Click on the Close button to exit the dialog box.

Collections and directories that are configuration objects will be displayed in the
Java Virtual Folders view with the configuration icon: 

To merge, restore or delete a configuration:

1. Right click on the configuration object in the Java Virtual Folders
window.

2. From the context-sensitive menu options, choose Configuration.

SAVE
CONFIGURATION

MERGE, RESTORE,
DELETE

CONFIGURATION
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3. In the Configuration Control dialog box, click on the configuration you
wish to merge (or restore or delete). The selected configuration will show
with a blue shadow.

4. Click on the Merge (Restore / Delete) button.

5. Click on the Close button to exit the dialog box.

If you double click on any version in the Configuration Control dialog box, a
secondary dialog box will appear, displaying the comment that was entered when
that configuration was saved. See Figure 30.

Figure 30: Configuration control dialog with configuration comment

The Select button in the Configuration Control dialog box allows you to select a
saved configuration for display in Java Virtual Folders (and consequently on the
Hyperwave Server).

In normal circumstances, the current configuration is displayed (all previous
configurations are stored outside the server). If you select a previous
configuration from the listing and click on the button Select, this configuration
will be displayed instead.

The configuration is displayed normally in the Java Virtual Folders view, with a
note after the Title indicating its configuration version number, e.g. (C1.2).

VIEWING COMMENTS

DISPLAY PREVIOUS
CONFIGURATIONS
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3.10 Setting Preferences for
Added HWIS Collections

When you click with your right mouse button on the mount point of a HWIS
collection that you added in Java Virtual Folders, an option appears on the
context-sensitive menu that does not appear for other objects. This option is
named Preferences, and allows you to customize how Java Virtual Folders
uploads your documents, and many other aspects.

The dialog box that opens when you select Preferences from the context-sensitive
menu has seven tabs. The first of these is labeled Upload Replace Options. In
this dialog box, you can instruct Java Virtual Folders how to behave when you
want to upload a document that already exists on the server (see Figure 31).

Figure 31: Preferences: Upload Replace Options

UPLOAD REPLACE
OPTIONS



38

Hyperwave Java Virtual Folders – Using Java Virtual Folders

Figure 32: Preferences: Upload Access Rights

The second tab in the Preferences dialog box is labeled Upload Access Rights.
Here, you can decide that documents to be uploaded should have the same rights
as the collection you are putting them into (this is the default option), or you can
set individual rights for documents (see Figure 32). You can use the Rights
Wizard to help you set access rights. The Rights Wizard is explained on page 27.

UPLOAD ACCESS
RIGHTS
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Figure 33: Preferences: Upload Version Control Options

The third tab in the Preferences dialog box is labeled Upload Version Control
Options. Here you can determine how Java Virtual Folders should apply Version
Control options to uploaded documents. You can choose to force a check in on a
document (it is automatically put under Version Control when it is uploaded to
the server) or, if the document already exists and is already version controlled,
you can choose to commit the version you are uploading as the latest version. See
Figure 33.

UPLOAD VERSION
CONTROL OPTIONS
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Figure 34: Preferences: Upload Options

The fourth tab in the Preferences dialog box is labeled Upload Options. Here
you can select the checkbox Absolute links for out of scope targets. This option
helps you to ensure that link consistency is maintained when documents are
being moved between a Hyperwave Information Server and a local file system.
See Figure 34.

UPLOAD OPTIONS
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Figure 35: Preferences: Download Options

The fifth tab in the Preferences dialog box is labeled Download Options. Here
you can specify how Java Virtual Folders should behave when the objects you are
downloading to a local file system contain or consist of links to other objects.
You can also specify how Java Virtual Folders should behave when errors occur.
See Figure 35.

DOWNLOAD OPTIONS
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Figure 36: Preferences: Version Control Options

The sixth tab in the Preferences dialog box is labeled Version Control Options.
Here you can select whether or not you are given the option of checking out
versions other than the most recent version when you choose Check out from
the context-sensitive menu. See Figure 36.

Even if you do not have this preference set, you can always choose to check out a
previous version of a document by accessing the Check out function in the
Version Control dialog box.

VERSION CONTROL
OPTIONS
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Figure 37: Preferences: Document Classes Runtime

The final tab in the Preferences dialog box is labeled Document Classes
Runtime. In this dialog box, you can set preferences specific to the Document
Classes feature. See Figure 37.

3.11 The Link Map

You can click on any object in Java Virtual Folders and display its related
documents in the form of a Link Map. The Link Map shows all links to the
document and all links from the document. With the Link Map you can also
browse the relations of other displayed documents.

3.11.1 Viewing a Document’s Link Map

To display the link map for a particular object:

1. Click on the object with your right mouse button.

2. From the context-sensitive menu, choose Link Map.

DOCUMENT CLASSES
RUNTIME
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The Link Map appears, showing all links to and from the document. See Figure
38.

Figure 38: The Link Map

The menus in the Link Map toolbar are File, View and Help.

The File menu allows you simply to quit the Link Map window.

The View menu offers several options for viewing the Link Map.

The Back and Forward options allow you to move between views you have
already loaded in the Link Map (much the way back and forward arrows work on
a web browser). The Refresh option refreshes the Link Map view after you have
made changes.

The Center option centers the view in the Link Map window.

Note: The Back, Forward and Refresh options are also all available as buttons on
the Link Map toolbar, and the Center and Refresh options are also available by
clicking with your right mouse button in an empty part of the Link Map view.

Under Options you can specify several aspects of how items are displayed in the
Link Map window. These options are explained on page 45.

The Help menu gives you access to online help and information about the tool.

3.11.2 Browsing in the Link Map

When you click with your right mouse button on any of the documents on
display in the Link Map window, a context-sensitive menu appears with the
options Focus Object, Open in new Link Map, and Properties (see Figure 39).

THE FILE MENU

THE VIEW MENU

THE HELP MENU
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If you select Focus Object, the Link Map view will change to display the links to
and from the document you have just clicked on. You can return to your
previous view using the back arrow ( ).

If you select Open in new Link Map, a new Link Map window will open
displaying the links to and from the document you have just clicked on. The
result is the same as selecting Focus Object from the context-sensitive menu,
except that you have a second Link Map window open, with your original view
preserved in the first window.

Figure 39: The Link Map with object-specific context-sensitive menu

If you choose Properties from the context-sensitive menu, a dialog box will
appear listing the properties for that document, as described on page 17.

3.11.3 Link Map Viewing Options

You can specify several aspects about how you would like the Link Map to display
information, including the colors used, the number of levels of hierarchy shown,
labeling and spacing.

To set viewing options for the Link Map select View È Options. There are four
tabs in the Options dialog box: View, Color, Label and Layout.
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Figure 40: Link Map View Options: View

Under the View tab you can specify how many levels of links you want to display
for both incoming and outgoing links. You can also specify which link types you
would like displayed. See Figure 40.
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Figure 41: Link Map View Options: Color

Under the Color tab you can select color schemes for displaying different types of
links. These color schemes are completely modifiable. You can click with your
right mouse button on any of the displayed color schemes (e.g. "annotation") and
modify the colors used for Text, Background or Bounds (outlines). You can
also change the overall background color for the Link Map, and return to the
default color scheme. See Figure 41.
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Figure 42: Link Map View Options: Label

Under the Label tab you can choose whether the Title or Name attributes of
documents should be displayed. You can also choose a font type, size and weight.
See Figure 42.
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Figure 43: Link Map View Options: Layout

Under the Layout tab you can modify the horizontal and vertical spacing of the
elements in the Link Map view. See Figure 43.

3.12 Drag and Drop

You can move objects in Java Virtual Folders by dragging and dropping them
from one location to another.

If the object you move is a collection, all descendants of the collection will also be
moved.

To move an object, simply drag it from its current position to the collection or
hierarchy where you want it. If you try to move an object from a Hyperwave
Information Server to a mounted file system (or vice versa), Java Virtual Folders
will perform a copy action instead.

MOVE
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To copy an object, drag it and drop it in its new location while holding down the
Ctrl button. Your mouse pointer will show with a small plus sign (+).

To link to an object, drag it and drop to the location where you want the link,
while holding down your Alt button. Your mouse pointer will show with an
arrow sign.

ì Select individual objects by clicking on them.

ì Select multiple objects that are not next to each other by holding down
your Ctrl button and clicking on them.

ì Select groups of objects by holding down your Shift button and clicking
on the first and last elements of the group.

Note: You cannot move objects to a collection if you do not have write rights for that
collection.

3.12.1 Keyboard Shortcuts in Java Virtual
Folders

Keyboard Shortcut Function

Ctrl+N New Virtual Folders

Ctrl+W Close

Ctrl+Q Exit

F5 Refresh

F1 Help

Ctrl+X Cut

Ctrl+C Copy

Ctrl+V Paste

Ctrl+L Link

Ctrl+Shift+L Link Version

Delete Delete

Ctrl+A Select All

Ctrl+I Invert Selection

Alt+Enter Properties

Shift+F10 Open context-sensitive menu

C Center (Link Map)

3.12.2 Sorting Information in Java Virtual
Folders

In Java Virtual Folders, the right-hand window displays the contents of whatever
collection or directory you clicked on in the left-hand panel. This display

COPY

LINK
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information has the headings: Title, Name, Author, Version, and Modification
Date.

To sort the object display by any of these headings, click once on the heading
name in the right-hand Java Virtual Folders window (e.g.Title). Click on this to
invert the listing under that heading. There is a blue arrow next to the selected
heading, which indicates the sort direction. (See Figure 44).

Figure 44: Sorting listings in Java Virtual Folders
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